WiFi on Cloudbit resets when I test the slider function with a servo

Really odd problem just started this evening. I have a Cloudbit successfully connected to the Cloud Control page, and it is connected to a servo. Whenever I try to use the 0 - 100 slider function under “SEND” the servo moves just a little bit and the Cloudbit loses its WiFi connection (goes from solid green to white, to blinking green, back to green).

I tried connecting an LED light to the Cloudbit (removing the Servo) and pressing the big purple button on the “SEND” page makes it turn on/off as expected without loss to WiFi.

I’ve been able to repeat this consistently. Here’s my bit configuration:

USB BIT (connected to USB wall plug adapter) + CloudBit + Servo

Have also tried:

USB BIT (connected to USB wall plug adapter) + extension bit + CloudBit + Servo

Any thoughts or ideas?

1 Like

Hi @eriksr, Are you using the littleBits wall plug and cable? The cloud bit needs a 2 amp power supply. Servo motors are also power hungry when they start to move, I suspect that is what is causing the problem.

Ahhh, very good point. Will test this tonight!

I will second the solution. If you go to the cloudbit page it states that it needs the USB power in order to work. You can sometimes get away with the battery, but it will start to reset consistently as it drains.

1 Like

I’m having the same issue despite being on a 2.4amp USB port. I even tried the included USB to AC adapter, no go suddenly.

Servo motors can draw HUGE current when starting, changing directions, especially under load. Try using a separate power source for the servo. See here.

I am experiencing the same issue. I have exactly 0 soldering skills and I have done only the most basic of proto- breadboarding. (I also do not have the HDK. :stuck_out_tongue:)
Yes, I am using the USB power bit connected to a wall plug. My circuit is USB power bit, button, cloudBit, Split, split branch one goes to a number bit + servo, branch two goes to the Lightwire bit.

For the short period of time the servo works, I can visibly see the lightwire flicker every time the servo changes direction. I have noticed that if anything else is plugged into that same outlet, the servo resets the cloudBit in a very short period of time. If the outlet is only occupied by the littleBits wall plug, it seems to reset after a significantly longer time period.

I acknowledge that it could be really be my house, actually. It’s 100 years old and does not have the most up-to-date wiring LOL.
If that is what it is, any tips for regulating/prioritizing the flow of electricity for/to a single outlet?

Are there any simpler (even if less effective) ways of minimizing this effect?
Thank you! :smile:

1 Like

I solved this problem by adding in a second power module to feed just the servo bit, like this:

See this project for more power separation ideas I have played with.

i have the same problem. i’m thinking that it’s a problem with the servo versus with the power. because, i’ve seen videos of people with it working - and people with videos of it broken. here’s the error (video should have gone longer… showing that it only wiggles that one time - and is then dead after that - and wifi often will reset… blink green). and here’s a video of someone who’s got it working (of of battery, incidentally):

this is my first littlebits. what a bummer!

crap, i’m not allowed to post links. will just give the youtube ids instead:

1 Like

A neat trick is that you can use the secondary input on the number bit as a way to smuggle power in. I’ve not used it for putting two powerbits into one circuit, but I’ve used it to create a circuit that went:

number -> cloudbit -> wire -> thermometer -> loop back to the number

…with the power going into the number bit. I needed the wire to keep the thermometer away from the cloudbit, since those get warm, but the powerbit often doesn’t like it if there’s a wire between the power and the cloudbit, so it solved that too.

1 Like

HI @brig, please send us an email at support@littlebits.com so we can help you troubleshoot.

I had this issue with the original USB charger power adapter. The issue was gone after I switched over to an 12W ipad charger.