Scratch 1.4 and littleBits


We at littleBits have put together a modification of the Scratch for Arduino Project (S4A: It uses a specially modified version of Scratch 1.4. We modified their code so that you can use it with the littleBits Arduino Module directly.

Scratch 1.4 is great if you don’t want to, or can’t, use the browser-based Scratch 2.0. We’ve posted our source and some helpful binaries in github. You can also use this link to directly download the files you need to get started (Mac OS X version).

Please try it out! We have a nice little tutorial posted in the github as well, or click here to download the pdf guide.

If you have any questions about it, just ask us for help in this topic thread.

Also big hat tip to our users abee and Kreg who’ve also been working to get Scratch and littleBits to play nice.


I downloaded S4A and opened “littleBits Scratch” but S4A keeps searching for the Arduino board. I unplugged again and again, and even tested with blink.ino. If I know what port the Arduino is on, is there somewhere in S4A to select that port? My circuit is power + d0 Arduino d1 + led … Also, is there an .ino file I should download?

Hi Jude-

Alin’s advice:

S4A is probably looking for the Arduino board because you’re Arduino Module is not programmed yet. You are absolutely right, you need the .ino file to setup the Arduino Module.

Find it here:

I’ve had very limited success with the S4A extension so far.

Mac OSX 10.9.5 - Analog Pong and Blink work. LB_S4AFirmware.ino loads. Scratch (S4A) finds board, but only lights d1/tx (d0/rx remains off). The input a.0 shows the pot value in S4A, but will not send to d9 through S4A to the Number bit. I also am not able to set a5 values on the Bright LED.

Windows 7 Pro SP1 64bit (two systems) & 8.1 Pro 64bit - Analog Pong and Blink work. LB_S4AFirmware.ino loads. Scratch (S4A) says searching (even if assign the board manually to the serial port), yet it only lights d1/tx briefly. The input a.0 shows the pot value in S4A for a second if I disconnect the Arduino unit. Tried changing COM from 3 to 5. No change.

Linux Mint 17 64bit - Analog Pong, Blink, and S4A worked. Both d0/rx and d1/tx lit, could send pot value to a9 and turn on LED through a5. However, the S4A deb install made Linux inoperable after reboot (if you look at details on S4A15.deb, it has a list of things it will uninstall, including Cinnamon and Nemo). No worries. I needed to test Linux Mint 17.1 anyway :smile:

Also, in Mac and PC, it doesn’t seem like S4A is loading the correct S4A.image file. It shows the Arduino littleBits image and logic briefly, and then reverts to the default Arduino unit (Base S4A). If I load the littleBits example SB manually afterwards, it changes to the correct sprite. To be clear, in Windows for example, I double click on the example and it fires S4A, asking me to select an image. I select the littleBits image from Git Hub, it shows the correct module briefly, then reverts to the default and does not load the example SB file. I have to manually load the file.

Hi @CRomer,

I know we talked in emails, but I wanted to let everyone know that we are looking into this. and we really appreciate your patience.

We will be in touch shortly with a followup.



Is there any news on this topic. I know this thread is old, but I hope to find some solution to my problem anyway? I am experiencing problems similar to @CRomer.

My laptop is running OSX Yosemite 10.10.5

I have installed the firmware for Scratch 1.4 on the arduino little bit. When I open the blank project, Scratch connects, and the board is shown. So far everything looks just fine, but nothing works. The board doesn’t respond to the code I write. I have tried all examples from this paper:

But with no luck. I seems like the board is not getting any information from my computer.

Any thoughts on this?

Hi there!
I am new to Arduino and LittleBits. I tried to follow all the steps but no luck so far.
I managed to install the driver in Windows so that Arduino IDE communicates with my LittleBits board. I uploaded the Firmware for S4A. However, when I open S4A it just keeps searching for the board without any success.
What am I doing wrong?
I am really looking forward to your help.

Hi @Ro_botika,
Welcome to the forum!

It seems that S4A is not (yet) working with the Littlebits Arduino Leonardo…
See this link:


What a pity that this was never answered. LittleBits Arduino had great potential but lacks software support & surprisingly no Scratch interface. For those wanting a Scratch interface for Littlebits Arduino try Makeblock’s mBlock. Select Arduino blocks under Robot, Leonardo and connect the port.