Problems to connect Arduino to S4A

I have problems when I try to start S4A
I have downloaded the files I need from Github and then uploaded them to my Littlebit Arduino. but when I start S4A the program can not find the Littlebit. Is there anyone who has been experienced something like that? And in that case how did you solve the problem?

Is S4A the Scratch language?
Here is a thread here with instructions.

Hi @jonaspaulsson,
Maybe this link could also be interesting for you :smile:

Yes its the Scratch-language (Scratch4Arduino) http://s4a.cat/

Hi @jonaspaulsson,
Did you also download and install the Arduino IDE ?
This software package includes the neccessary drivers so your computer can recognize your connected Arduino.
See:
https://www.arduino.cc/en/Main/Software

:grinning:

Hi Alex!
Yes I have downloaded and installed it. I have worked with Arduino IDE a little before. I have tried to download from GitHub at this page: http://littlebits.cc/education-scratch-extensions

Hi @jonaspaulsson and @JackANDJude and @chris101,

S4A (Scratch for Arduino) does not work for the Littlebits Arduino W6 Leonardo.
there is another forum thread where it shows that the team is working on an update on the ino file that must be loaded into the W6.

But in the meantime I tried another scratch-lookalike: Snap4Arduino.
It works with the Littlebits Arduino, however with a few restrictions.
You can download the neccessary files at:

http://s4a.cat/snap/

There you find all the files needed and a very clear explanation how to install.

I tried it and found that the Littlebits Arduino W6 can be used.
You can use the analog input connections and the digital outputs, in digital mode and in PWM mode.
The Servo selection in the Snap software does not work, instead you can use a digital output in PWM mode.
I used the following bit setup:
Power + button on A0
RGB Led on D5
Servo on D9

this is the snap program to test the servo, slowly moving when the spacebar is pressed:

And the program to test the button, it moves the sprite in the Snap screen…

One remark:
When a bitsnap gets loose by acciddent the program needs a restart…
:grinning:

Thank you very much for your answer. I will try it out asap! I have worked a little with this plattform; “Makeblock” http://www.makeblock.cc/

1 Like

Hi @jonaspaulsson,

Another tip:
Maybe Ardublock is something for you !
It is a visual block type programming environment for Arduino and also they have special blocks for your makeblock !
See:http://blog.ardublock.com/2013/10/31/beta-20131031-makeblock-do-while-and-adafruit-dc-shield/

They only have a blog website, but it is clearly explained how to install the package.

WOW, did it ever take a long time to figure out that this is a universal problem, not something wrong with me.

I hope that when there’s a fix that lets the little bits arduino talk to s4a (or some other version of Scratch) that I’ll find out about it by following this forum…