Official cloudBit™ Troubleshooting

Thanks, @jeffpiep! I’ll share your point with our cloudBit engineers. :slight_smile:

Hi @jeffpiep - sharp eyes! We’ll take another review at the i.MX reference documentation. I don’t know if splitting the ground plane is an option with this MCU - I recall reading an application note that recommends connecting analog ground pins directly to the main ground plane as close to the pin as possible. You might want to be careful about separating the analog and digital ground planes - the output opamp can sink a considerable amount of current into ground if it’s driving a heavy load, and i’m not sure that the i.MX is capable of routing that current through the analog ground pins. We’ll double-check!

One recommendation I do have would be to keep your power supply as close to the CloudBit as possible. In many cases a degree of ground/VCC-bounce can be caused by current transients passing through other modules (particularly wire modules). This can be an issue with any of the really power-hungry bits - Cloud, Servo, DC Motor, Fan.


Just bought a cloud bit this evening. My son and I have enjoyed the gadgets set he got for Xmas. Couldn’t get past the blinking green LED light this afternoon. I have read most of the forums on here regarding the issue. I have checked all wireless network recommendations and the port check. Any input is greatly appreciated as my 5 year old is dying to get this to integrate with his minecraft world. Also, just checking, but is there an ethernet access for cloudbits that would allow a desktop (gaming desktop) to communicate directly with cloudbit (i know the name…cloud…)Thanks in advance for any suggestions. ticket # 65964

How are you powering the bit? The Cloudbit is power hungry so needs the USB power to work. Preferably plugged into the wall adapter.

Also check to make sure that the SD card is correctly installed. It is the type that if you push it in it pops it out a little so you can remove it.

Not sure about the ethernet access. I believe you have to communicate via the internet so you can communicate from any internet connected computer that way.

Im having an issue of all a sudden with the cloudBit.

For some reason it has stopped POSTing to my server. I’ve checked the devices subscriptions and it has a subscriber ID and publisher_events associated to it (amplitude:delta:ignite) Is anyone else having the same issue?

Ive checked the cloud control test sequence and it is working there so its something to do with “

Heres how i know nothing is being POSTed

$postdata = file_get_contents(“php://input”);
$jsonObj = json_decode($postdata);
$type = $jsonObj->type;
$data = $jsonObj->payload->percent;

$myfile = fopen(“coffee.txt”, “a”) or die(“Unable to open file!”);
fwrite($myfile, $data . PHP_EOL);

Hi @marklochrie,

Care to try once more and let us know?

Just tried and nothing

@marklochrie just sent you a private message asking for some more data.

I need help! I’m having trouble with the Cloud Control, I can’t connect my module.

i am having trouble with cloudbit sd card

first, i don’t know but maybe i am not doing right but
i inserted the SD card in the adapter then in the computer. But it says
'‘The disk you inserted was not readable for this computer’'but when i insert the mp3 player it does not says like that.

thank you

:frowning:i am so sad

Hi @alfaalfa,
The cloudbit SD card contains special software only suitable for the cloudbit and should never be removed.
You can send a mail to for instructions how to reinstall your cloudbit SD card… :grinning:
or take a look here:

or here if you want to reinstall the SD card software:

so much thanks @alexpikkert ive been looking all the forums but its my fault…

1 Like

Hi , I’am a STEM trainer at Edutech india ,Bangalore.
I’am comfortable with the basic bits, iam facing a problem with CLOUD BIT and Even not understanding how to connect CLOUD BIT to IFTTT & LITTLE BITS APP .
So this is the first time iam teaching little bits,And thought few concepts on input & output bits,But organisation is expecting me to learn cloud bit and Aurdino bit and so i need this help from you guys,
So if you send me steps so sort the cloud bit issue i may not understand,
So can you teach me all the needs @skype ,If iam successful in learning CLOUD BIT , AURDINO BIT , SPEAKER & MUSIC BIT,we would like to buy CODER KIT , PRO KIT & WORKSHOP KIT,
As of now we have ,2 BASE KITS , 1 SMART HOME KIT , 1 AURDINO KIT , 1 STEAM STUDENT KID (Eventually we have all the kits but we are not able to explore )
So if you could help me through SKYPE it would be a great help to me.
Thank you
Edutech india

Hi Narasimha,

Thanks for reaching out! We would love to help answer your questions about CloudBit and Arduino Bit.

The first thing I recommend is following along with these helpful guides:

Our Customer Success Agent, Megan has responded to you by email. We’d love to continue the conversation there.

All the best,

Hey! I’m new to the forums and I hope that this is still the official topic for this. My CloudBit has been acting up twice, and the first time I solved it, but now, it has a really weird issue:

  1. Circuit -> 1A USB AC Adapter - USB Power bit - Button - CloudBit
  2. I turn on the circuit and get the steady white light for about ten seconds.
  3. The light turns blinking green for about 5 seconds. Then, it goes back to white, repeats step 2-3 twice and then gets stuck on white light.

I did these things:

Replaced the input module to make sure that it wasn’t malfunctioning.
Removed the input bit completely.
Followed the steps for both “change WiFi” and the setup process after I deleted the CloudBit from my account. However, when I did this, the blue light did show up a few times, but it was only blinking one time and then the status light turned back to white.

###So, I think that this can be the error sources:

My AC Adapter gives too low power (I’ll try changing it to a 2A and if it works, I’ll let you know. If not, I’ll let this post stay here)

My CloudBit has gotten some weird code fault: and I don’t have the courage to check the SD card in my computer.

Also, my CloudBit is about 1 year old exactly, so I know that I can’t return it, but I hope that I could get some support from you: whether it’s from the community or from the LittleBits team. Thank you!

I can’t connect the cloudbit with the cloud in bit control layout. After I set up the cloudbit and WiFi connection, it still stated that it is disconnected So, what should I do ?

Hi Cindy, please send us an email at and we’ll help you troubleshoot.

Hi everyone! I’m having trouble connecting some of my cloudbits to cloud control. At step 3 of connecting, the connection drops few seconds after I switch wifi to littlebit_cloud… and the screen says waiting for device to respond or something. Sometimes it goes to the next step and let me choose a wifi network but then it drops again. I sent a mail to support but trying here as well… Is anyone having the same issues ?

this is an old thread but still a problem I had just today.

this is what happened for me…

If you are connecting from an android phone and getting the waiting spinning thing in your browser, go over to your android wifi settings again. sometimes there will be a dialog box, asking if you still want to connect even without internet. IF you click ‘Yes’ button, it should let you through to the next step in the browser. At this step also there is a checkbox to remember your decision for next time.

I somehow accidentally deleted the software I have a Linux Chromebook
Can you help me