Official bitCraft Troubleshooting

@cheeseman36 I’m sorry you’ve been having trouble with it. Can you tell me what operating system you’re using, and what version?

Stan,
I cannot get the mod to download. I am using Windows 10. The page layout is nothing like what is in the guide. Any help would be greatly appreciated.

Thank you,

John

@jwitt317 oh no, I’m happy to help! Can you tell me where you’re getting stuck? Are you able to download Technic launcher? Can you find the mod in Technic launcher when you search for it?

In the Technic system I can find the Bitcraft page; however, there is no “install” to click on. There is a pull down menu on the right side of the page but when I click on “Copy Platform URL” nothing happens. What am I missing?

Thanks,

John

@jwitt317 Ahh, I understand! There’s actually a “Technic Launcher” program you have to install to get the mod. Here’s how to do it:

  1. To get the Technic Launcher program, go here: http://www.technicpack.net/download
  2. If you’re on Windows, click the “Windows” button to download the correct version,.
  3. Once it’s finished, launch it. You’ll be asked to login with your Minecraft account.
  4. Once you’re logged in, there will be a set of tabs at the top that say “Discover”, “Modpacks”, and “News”. Click the one that says “Modpacks”
  5. There will be a search bar on the left. search for “littlebits” or “bitcraft” or both. You should see the littleBits bitCraft pack appear.
  6. In the lower-right-hand corner, click the “Install” button. Once finished, click the “Play” button in the same location. That should do it!

You’re definitely not the first to have trouble with this, I’m planning to modify the Getting Started guide once I’m back in the office so it’s clearer for everyone. Also, just wanted to let you know we’re going to have a custom bitCraft launcher soon that will be a much simpler install process.

Let me know if you have any more trouble, I hope that helps!

Thank you Stan, you the man. My kids had a blast in your demo world.

Thank you,

John

Soooo glad to hear it, no problem at all!

Can you explain why the bitCraft gateway doesn’t respond to the transmit widgets on control.littlebitscloud.cc and vice-versa? (I have no trouble using bitCraft with littlebits i/o modules, just thought the cloudBit might relay a signal - or do I need to use IFTTT for that?)

Hi @jeffpiep

That’s a good point, that’s something I’ll look into. I believe it’s related to how the cloud API operates, but I’m already trying to tie the mod in with IFTTT integration, and this issue fits in with that. I’ll add it to my to-do list.

1 Like

this may be a dumb question - I downloaded the Linux version. I can’t figure out how to launch it ?

@CheleB Definitely not dumb, this gave me a moment of pause too when I installed it on my linux laptop. I’ll give you two different ways to do it, just in case.

The easy way: Find “TechnicLauncher.jar” in your file explorer, wherever you saved it. Right-click it and choose “Open with.” Select the option that looks something like “Oracle Java 8 Runtime.” That should do the trick!

The terminal way: Open a terminal, and move to the location of “TechnicLauncher.jar”. If it went to your Downloads folders, something like:

cd ~/Downloads

…should do the trick. Then, type:

java -jar TechnicLauncher.jar

…and press enter. That should works just as well.

Let me know if you have any more problems!

Help…we are having a similar problem as the poster above; my son has confirmed the bitcraft mod is properly downloaded in the Technic folder. Every time he presses play on the Technic launcher to play the mod, the launcher goes away for 1-5 seconds then comes right back but Minecraft doesn’t launch. We have Windows 10. Thanks for any thoughts!

Hey @tewashen! I see your problem! Here is a list of things to try:

  • Delete technic from your computer(make sure that it is completely erased and not in the trash bin), and reinstall technic. Doing this will make sure you have the latest version of technic.
  • Delete the mudpack and reinstall.

Hope I helped!

Hi, I followed the getting started guide, downloaded the Technic launcher and installed the BitCraft mod. So far so good…

When I try to play the example world I get a warning about missing blocks which will be removed, relating to “Tabula Rasa” (see pic below).I see this referenced as a mod in various forums but it seems not to be something that can be downloaded via Technic Launcher,

Advice appreciated. Thanks,

Alex

It looks like I can just continue past this and it doesn’t cause issues

In a bitcraft world (single plaer) I can’t connect a cloudbit. I get an error “Hmm, looks like there’s a problem, check your internet connection and try again”. Internet connection is fine, and cloudbit is authorize too. I tried to paste token but nothing.

What color (and blink state) is the LED on the cloudBit?

Whenever i try to connect to bitcraft with my little bit it sends me to the site where i authenticate it and then i click it, it says it is authenticated and then i go to minecraft, pops up with “Hmm, looks like there’s a problem, check your internet connection and try again.” and my internet is working fine. I have tried many times. Any help please?

I’m sort of new to MineCraft mods so sorry if this is a n00b question. I currently play on a Minecraft (Java Edition) server and I would love to use this there to detect and alert me when say someone enters my house. Can this be installed on a server or is it only something you can use and run locally?

hi, whenever I try to get a token from the littlebits website I just have a blank space with nothing to copy/paste. Is it still up?