"Not recognized"

My Arduino bit was working fine. I went to load a new bit of code, it hung for several minutes, and now none of my computers will recognize it. I’ve tried it on a 32-bit XP laptop and a 64-bit Win7 desktop. I’ve tried two sets of USB cables. I’ve tried replugging it. Depowering it a couple of times in rapid succession. Switching the analog switches to PWN. Unhooking the other bits. Rebooting the computers.

When I plug it in the “Arduino Leonardo bootloader” will show up as COM5 for a few seconds. Then it vanishes and I get a new “Unknown device” in my device manager.

Has anyone had this trouble? I’m worried I’ll need to reflash the bootloader. Any suggestions would be welcome. Thanks.

1 Like

Here are the instructions that I got from littleBits engineers when I had this problem. It got the Arduino back up and recognized again. I think the sketch that I loaded was requesting more memory than the Arduino has.

“1) Short the pins in the attached picture (i.e. directly connect them to each other):
2) Connect the USB to the Arduino and turn the power on to the Arduino.
3) Press ‘upload’ in the Arduino IDE with a code that is known to not cause issues.
4) When the status bar changes from “compiling sketch” to “uploading…” remove whatever you are using to short the two pins.
5) Your sketch should now successfully upload.”

The pins you need to short are a2 and d10. I just placed a small piece of wire in those two pin holes and held them tight while doing the above procedure.


That did it! Thank you!

I did the same thing trying to load a bigger program than there was memory. Let that be a lesson, a 10,000 integer array will not fit on a littleBits Arduino. :slight_smile:

1 Like

Glad to hear that it worked for you as well!

1 Like

Did you try a fresh battery? The Arduino stops working correctly well before other bits stop working.

Hi Rich,

I’ve the same issue here.
I tried the above procedure but it didn’t work.

Then I checked this link:

The point is you have to short the Rest and the GND pins, not a2 and d10. :smile:

Thanks for the solution!