MP3 player will play randomly without input

Can anybody help?

I have an MP3 player bit that will randomly play a single track after being on for a few minutes.

Hi FramerX :slight_smile: I replied to your PM with a suggestion and a couple clarifying questions. Let’s continue the chat here so others can benefit.

Here is a suggestion. Try putting an led before the mp3 player, so you know when it is getting a signal. Even better than an led would be a bargraph or number Bit, because they would give you more information.

A couple questions for you:

  1. What is the other wireless circuit?

  2. How long are the files on the mp3 player?

Here is my setup.

The wireless little bits receiver is receiving a signal to play without me even having the transmitter on.
There is a 2 channel wireless relay next to the little bits components. Is it possible that the remote from the relay is causing it? It does it periodically.

Would the little bits transmitter/receiver with multiple channels fix this issue?

The files on the MP3 are the little bits stock tracks.

Hi @FramerX,
Are you using one power supply for all components?
Maybe it will help if you separate the 5 Volt power supply for the Littlebits part from the rest of the circuit. (by using 2 separate power supplies)
It could be caused by noises (interference, voltage drops or voltage spikes etc) from your circuit.
:jack_o_lantern:

2 Likes

Hi alexpikkert,

It is all connected to the same power source! I was kind of thinking it could be exactly what you said. Thank you for the reply.
I’ll give that a try.

2 Likes