Microphone bit not sensitive enough

Hello, I’m trying to use the arduino bit to measure average sound level with a microphone. When I use the microphone in other mode, the sound needs to be really loud for it to detect anything using analog read. If I use a sound source connected to the 3.5 mm input jack, I get good results. Any ideas on how I should solve this? Thanks

Con,

You might try the following (it requires a few more little bits though):

Little Bits Schematic:
[Microphone]+[Speaker/Synth]+[Microphone]

  1. Connect your mic to the 1st Microphone Little Bits.
  2. Connect your speaker/synth microphone output into the 2nd microphone little bits
  3. Adjust the volume/amp on the Speaker/Synth module

-derek

Hi Derek, I’m working with Con on this science fair project. He wants to use the microphone bits built in condenser mic. The audio levels needed to read anything with the Arduino pin a0 are really loud. (we scared the dog!) When we used the 3.5mm input fed by a microphone application on my phone normal conversational levels can be measured and compared. He wants to put a pair of microphone bits in a stereo arrangement to compare levels to determine if the sound source position on the left or right side of person that can’t hear. It sounds like the condenser mic needs an pre-amp to be measured by the Arduino. This might be a nice enhancement for version 4 of the Microphone. I’m afraid your suggestion hurts the project budget. We might need to build something on a perf baord. Thanks!

Hi… I recently purchased the i21 microphone to use with my w6 Arduino and I’m having the same issue. The microphone appears to require a very loud sound in order for the Arduino to detect the input. I also tried to use the microphone output with the 021 number display, and it only displays single digits values with my iPhone speaker directly above the microphone with the volume at max.

Were you able to resolve the issue? Are there any other options available?

Thanks!
Chris

I tried this with my project (drum trigger) to bring up the level of the microphone bit – but no success, but just had a little Eureka/SMH moment …

I think what I was missing from your suggestion is using a 1/8" cable output from the speaker bit into the 2nd mic bit (at the ‘other’ setting). 1st mic bit set to ‘sound’. Gonna try that config next.

Thanks for the tip!

This config didn’t work for me – was not able to bring up the mic sensitivity