littleBits Arduino doesn't respond anymore!

Hi everyone,

I tried to control the Servo Bit using littleBits Arduino, then the
Arduino board disconnected and the USB port comes unrecognized!

But this Arduino was working before trying the Servo Bit! It stops working once I connected to the Servo module only!

What is going on? And how to solve it?

Since I’ve 3 Arduino Bits with same issue!


Hi @mohsh! Here are a couple questions to help clarify the problem…

  1. How does the servo behave without the Arduino? Does it work properly in this circuit: power + dimmer + servo?

  2. With my computer, I need to reselect the port every time I upload code to it. I’m no IDE expert, but could you please let us know what operating system you are using and the version of Arduino you downloaded?

Talk to you soon! :smile:

1 Like

Hi @JackANDJude,

Thanks for your help, I found a solution on the forum, here:

Then I correct the connection by your link:

Now it works!

Thanks again.


1 Like

I encountered the same problem. But the solution had nothing to do with what worked for mohsh which is also detailed in It was simply that the battery had run down even though there was no indication of it. (The led bit was lighting up fine). So, before trying other remedies replace the battery!

1 Like

Hi @SAS,

I’m glad your arduino bit fix was easy! Don’t you love it when it’s a simple solution? :smile:

There is a simple mod you can do to the bit (it was designed so you could make the modification by the bit’s designers) that makes it so you can power it from the USB cable. If you are an intensive arduino user, you might want to consider doing this. It does take a little bit of soldering skill.

Look here: Can't get the USB port to show on my Mac

From my experimentation, you can use this method safely, even when a power bit is also attached to the Arduino (or other connected bits.) In fact, I often put an unpowered usb power on input bits, because that causes them to work properly.