IFTTT Recipe not being triggered from cloudbit

Hi

I am having an issue with my cloudbit and triggering a IFTTT recipe. I have a IFTTT recipe which says if my cloudbit is turned on, then send an email and another recipe which says activate the output of my cloudbit. None of the recipes have been run. I have tested my cloudbit from littlebits cloud control and I have also tested with the IFTTT app and do button which all work. I have the power, a button, cloud bit and buzzer to test and when i press the button or send any signal to the cloudbit, the IFTTT recipe is not firing. Any thoughts?

Thanks,

Ger.

Reply

A few things to check - is the cloud bit properly connected to your wifi? Have you checked it with the control panel? Then check it with a recipe known to work. Recently IFTTT was down for a day or so, so perhaps try it again tomorrow.

We have the same problem as Ger has for about a week now. We’ve been using the same proven and tried recipes. We can send output to the littlebits from IFTTT (i.e. put on a littlebit light with an sms), but somehow we cannot trigger IFTTT recipes with a littlebit button or other signal (both trigger on and trigger off do not work). The cloudbit control panel indicates that we do receive the signal online, so it has to be some communication problem between littlebits and IFTTT servers. Could you look into this?

You might get more response if you email support (at) littlebits.cc .

1 Like

Hi there @IoTAcademyNL. I just wrote to support. I had the same outcome after further investigation last night. My cloudBit could RECEIVE from IFTTT but not SEND. I will keep you posted.

Thanks for the advice @chris101.

We are looking actively to what may be happening between IFTTT servers and littleBits Cloud Platform since this is not affecting all users.

Thanks @pires

Please let me know if you need anything or for me to test anything. I had also opened a support request with the the details of what I have tried, what is working and not working.

@theodore_littlebits says “We are currently investigating the connectivity between our cloud servers and IFTTT because it seems like some cloudBits are not connecting with IFTTT 100% of the time. We definitely want IFTTT to be working well for everyone, so we’ll be in touch soon with a solution as soon as we can.”

@ger_mcmahon My cloudBits can RECEIVE from but not SEND to IFTTT. I will demo this to my today and tell them to stand by and stay cool. :sunglasses:

@Thingfully - your in the same boat as me and will wait patiently :smile: yum:

I know this will sound weird, but we are able to send stuff to IFTTT and other webhooks. However, we may have found an issue with how one instance - part of a fleet of instances - was finding IFTTT on the Internet (DNS) and have told itto behave properly.

That said, care to try out your recipes now and let us know?

@chris101 thank you for your help here.

Hi,

I have tested this and everything is now working perfectly. Thank you very much for all your help and getting the problem resolved.

Quick question. If i have multiple recipes with the littlebits channel on the THEN, will it fire all or just one of the recipes. It seems that only one recipe fires and it was the most recent one i created,

Thanks

ger.

@ger_mcmahon good question! We’d say it wouldn’t work but this is something that happens on the IFTTT side, so we can’t make any promises here. What we do is to have multiple recipes that share the same IF but have different THEN.

I will be closing this thread since it’s working.

Thank you all for reporting and bearing with us while we fixed it.