Help! Project creation broken?

I am trying to get my #HackHalloween project uploaded, but the project creation/saving interface seems to be broken. http://littlebits.cc/projects/hackhalloween-creature-in-the-cap

First, I created my whole project and saved it–and everything disappeared! I found a month-and-a-half-old thread saying this was an issue, but it still is not fixed.

I used the workaround mentioned and saved after I uploaded every picture and made a new step. When I edit, I see all my steps, but on the project page it only has step one. It also has the wrong video in the slideshow, even after I have deleted it/replaced it.

Help! How can I get my project uploaded properly?

Update: Tried starting from scratch, and no luck. It appears to save, but posting the project, none of the instruction steps show up. I also cannot upload an Arduino sketch at all. It never appears, in edit mode or otherwise.

This project does have the video I wanted, though. http://littlebits.cc/projects/hackhalloween-creature-in-the-cap-2

Hi Jeff @jeffriv,
There are two videos and six steps visible in your project nr. 2, so I think the uploading process was successful in the end…
Sometimes uploading fails indeed, I also tried to upload an Arduino sketch under sketches, but never succeeded.
I think this could be a bug in the system… You can however place a sketch under additional files.
And sometimes there is an unexpected time delay when uploading, then it only looks like a failed process at first.
I once removed one picture in an oploaded project and then the whole project disappeared but stayed on my profile page fully unaccessible. Strange things sometimes happen… :joy:

Btw, nice project !

I too have had this problem, there is definitely a bug in the system. I had to get help from support to upload my project. Come on Littlebits, sort this out please, we are all keen to expose our creations.

Glad to see it’s not only me, and that someone else can see the project!

Another bit of info: when I am signed in, I still cannot see any of the steps in my project #2. But I can see everything when I am NOT signed in.

Browser does not seem to make a difference, I get the same behavior on Chrome and Firefox (haven’t tried IE).

Hi, @jeffriv! I can see 6 steps and 2 videos on your project. :grinning: Your cap is a very creative use of motors and a phone!

I had problems as well. I ended up getting my project stuck with partial data. I ended up deleting the old and resubmitting. This seems to have worked.

Try downsizing your pictures. There is a limit on their size, it is set to pretty low.

1 Like

Even fairly large pictures will upload IF you save after adding each one. That’s one of the workarounds from the other thread. If you try to upload lots at once it seems to time out and your project doesn’t get saved. But going one at a time seems to work.

So, problems seem to be:

  1. Can’t see your own project steps if you are logged in.
  2. Arduino sketches don’t upload
  3. Project save/upload can time out if there are large images/lots of data and fail to save your work.
3 Likes

I have attached Arduino sketches as "additional files’ which then appear on the right sidebar.

Hi everyone - I’m a product manager here at littleBits for our website. As we are preparing for the holiday season, we have implemented caching features that will help us support the increased number of new visitors that will be coming to our website.

Right now, that means that any changes to a project (comments, likes, new images or steps) will take up to two hours to appear on the live site.

From a user experience point of view, this makes it look like your comment disappears right after you make it. Do not fear. That comment will show up, but it will be up to two hours in the future.

Sorry for the confusion. We will be looking next week at a way to make this a better experience.

Thanks,

-Nick

2 Likes

Thanks for the explanation Nick, but that sort of defeats the concept of an interactive web site. I don’t think I have the patience to build a project page if every image and every step takes 2 hours to appear!

1 Like

HI @nehle,
I still have issues with my projects, even when waiting two hours or more. Comments appear with some delay, this is not nice, but ok at least. Step-by-Step instructions works.
Embed videos with the “Embed code” will not appear on the project page. Sketches will also not appear.
I tried it several times, even saving each single change and waiting for several hours.

I already had the idea that it is difficult to make changes as soon as the project is published. Any advice would be very kind. :sunflower:
rgs

Hi @SeventhDwarf - Thank you for letting me know. We are planning to remove the two hour delay in publishing this week. For the problems with the embed codes, please send me a direct message with the details, including the embed codes that are not working and which project(s) you are trying to add them to.

Best,

-Nick