Getting Started with Arduino

Hi @Chuck,

The Arduino module can be powered using any of the 3 inputs or by using a fork, branch or wire module.

Great suggestion for the diagram! I’ll let the team know this is something you’d like to see.

Here is image of (poor man’s) USB scope of arduino d5 output in ANALOG mode (blue) along with PWM mode (red) for 50% duty cycle. The littlebits RC/opamp filter does a nice job of converting the PWM square wave to an average voltage – not much ripple.

hello littlebit,
I bought the littlebit arduino kit. There is showing the setting on mac. Can`t i program on windows environment? If i can then what is the setting?

yes, possible on Windows of course
see images at
and follow steps given in the first post of this thread: you will need the Arduino IDE

hello little bits - I put my problem in the processing app but maybe I should put it here.
I have loaded up the arduino software and used in successfully with a standard arduino.
I plugged in the little bits arduino and got the following error message
This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
Arduino: 1.0.6 (Windows 7), Board: “Arduino Leonardo”
C:\Users\Home\Downloads\arduino-1.0.6-windows\arduino-1.0.6\hardware\tools\avr\bin\avr-ar: unable to rename ‘core.a’; reason: File exists
core.a(main.cpp.o): In function main': C:\Users\Home\Downloads\arduino-1.0.6-windows\arduino-1.0.6\hardware\arduino\cores\arduino/main.cpp:40: undefined reference tosetup’
C:\Users\Home\Downloads\arduino-1.0.6-windows\arduino-1.0.6\hardware\arduino\cores\arduino/main.cpp:43: undefined reference to `loop’

Is it because I used my Pc with the arduino before?
Do I need to clear something?
I have checked it is on com 9 and set the board to leonardo

Further on ‘Getting started’, one item I found frustrating was installing the unsigned USB driver. Although some Windows setups will allow you to install it, others will may just block the action with no other options. There is not much info
how to resolve this problem. Checking if a driver is signed or not is a changeable option. Press Start—>MyComputer—>Properties—>Hardware—>DriverSigning set to ‘Warn’ not ‘block’. Then reinstall the Driver again.

I haven’t had much luck getting Arduino to work. I only have the synth kit (two, in fact), and all of the Very Basic Arduino sketches I have seen make use of bits other than just those in the synth kit. (The projects and sketches that do involve the synth kit… none of them have worked.) Is there some VERY VERY simple sketch I can run just to see it work? I feel that would push me in the right direction. Something that, e.g., just pulses an oscillator… ?

@monumentalfolly I happen to be working on a program that will do just that. The goal is to output all 49 notes of the keyboard to the oscillator on pin 9. I’m not quite there yet, but it does make noise, lol.

int speakerPin = 9;

int Notes[] = {15,19,25,28,32,38,39,44,51,53,59,62,

char* CharNotes[] = {“C1”,“CS1”,“D1”,“DS1”,“E1”,“F1”,“FS1”,“G1”,“GS1”,“A1”,“AS1”,“B1”,

void setup ()
// pinMode (buttonPin, INPUT);
pinMode (speakerPin, OUTPUT);

void loop ()
{ for (int n = 0; n<=48; n++)
{analogWrite(speakerPin, Notes[n]);
analogWrite(speakerPin, 0);



I tried it and I got an error. Doesn’t

int buttonPin

need to be defined?

I added

int buttonPin = 1;

(I don’t have the button bit, but I do have the keyboard bit which I think would serve the same purpose?)

Adding that, and the code verifies, and works.

And actually, the keyboard bit doesn’t really do anything. I.e., with or without it at A1, the sequence of notes starts.

@monumentalfolly I Deleted the button part. It will play notes automatically over and over again.

@monumentalfolly I corrected the array in this code; the array shown now plays 3 times more notes than it did last week. I hope you are having fun experimenting with the Arduino. :smile:

Hi all,
do you have a procedure for W8 setup, I have some difficulties to connectect the COM port under arduino, the port is not recognize.

Hey @Supa,

Are you connecting the power module to the Arduino module while connecting to the computer? Also, what type of operating system are you using? I’m wondering if you have a port blocked. I could give you instructions to reset the module if you are still having difficulties.

Yes I have the power module plugged in the arguing while connecting to the computer. What is supprising for me by the way, as the USB can power the system like for the arduino UNO R3.
The port is detected ths first time and after a run he became unsuable.
I am running under windows 8 and not an expert of it.

@Supa, yes this is definitely possible! You would have to solder a couple of pads together to accomplish this. Did you read that on another post? Also, try resetting your Arduino with the following steps:

If this doesn’t work, try resetting the Arduino with these steps:

  1. Short the pins in the attached picture (i.e. directly connect them to each other with short strip of wire or a staple): The pins you need to short are a2 and d10. Place a small wire in those two pin holes and hold them tightly while continuing through the reset process.
  2. Connect the USB to the Arduino and turn the power on to the Arduino.
  3. Press ‘upload’ in the Arduino IDE with a code that is known to not cause issues.
  4. When the status bar changes from “compiling sketch” to “uploading…” remove whatever you are using to short the two pins.
  5. Your sketch should now successfully upload.

Let us know if this helps

Thanks for the tip in order to reset the arduino. I was aware of the procedure.
For the power, I do not feel comfortable to make some solder on it. I am going to test the USB power bit solution.

Have you attempted to connect the Arduino on another computer?

Yes and it works. Thanks

My IDE does not have the Leonardo board option, I’m using a Linux Ubuntu. I’m not sure what I should do about it! Please help! It says I need 140 characters to post this so, just ignore this bit! hfjfsjvfenjdbfkndfbnkgfdknfbkngbdndbfkndgbkjfgdkmdnighddjnhdnkjkkk

A3, A4, and A5? Is that right? Mine shows A2, A3, and A4. I actually need an A5 for the I2c protocol. Is there an A5 pin?