Connecting littleBits to Scratch 2.0

@mattgalvin and @ichowmille,
Thank you for your encouragement. I would love to see some of the projects your students end up creating with Scratch!

The modules that only have an on/off state like the push button have to have power running through them. Try connecting the power module directly to the push button and test again.

Something like the fork module is handy for this. It would let you route power to three different input modules connected to the Arduino bit.

@kreg Thanks for the tips. I recall now that you mentioned that during the hangout. I’ll try it again later and let you know how it goes. The kids already had lots of fun using the slide dimmer as input for their Scratch projects.

One quick question (probably just littleBits in general) – would you know why the standard know dimmer doesn’t seem to produce the same output range as the slide dimmer? When testing in Scratch, the knob dimmer doesn’t even break 100 and the slide dimmer reaches all the way to 245. Thanks.

@khanning Hello! I am trying Scratch for the first time today. I uploaded your .sb2 file to the online project editor. Do I understand correctly that plugin download is no longer necessary or supported? I installed the littleBits_Scratch_Extension.ino to the Arduino, but I can’t make my leds on d1, d5 or d9 light up. I can make the cat move, so that’s progress. Any pointers for a Scratch noob?

I haven’t noticed this behavior. I wonder if there’s different version of the modules? I’ll try to test this today and get back to you.

Thank you! I forgot to include that step above. The Scratch Browser Plugin IS required and is now step 1 in the instructions. Let me know if you have any trouble getting it working!

Thanks for your reply! I downloaded the plugin and ran it from my desktop. The installer was fast. However I don’t see a Scratch file installed anywhere on my computer. Is there an executable or other file name I can search for on my computer?

@khanning Perhaps I installed it correctly, as I was able to upload the .sb2 file to the online project editor? All I know is I can’t move that cute cat with an Arduino input. Please see my screen shot from my first comment.

Here is how you can check if the plugin was properly installed. If you are seeing a red dot next to the extension under “More Blocks” then the plugin may not be correctly installed.

Google Chrome

In your address bar type `chrome://plugins` and press Enter You should find the "Scratch Device Plugin" in the list:


In your address bar type `about:plugins` and press Enter You should find the "Scratch Device Plugin" in the list:

1 Like

The Scratch love continues! Check out @electronicadive’s new Scratch offline 2.0 extension. Project page: and Github files:

Have fun trying it out!

thank you very much for this wonderful interface. Me and my students have already enjoyed some time on my Mac computer. There everything is running perfect.

Nevertheless I have trouble in getting the software running on Windows 8.1 machines.

I am using the Chrome browser. I have downloaded the correct firmata on the Arduino using COM10. It is running with the Mac. The plugin is also working (it shows in chrome://plugins, and Lego Wedo is also working), but when connecting littleBits Arduino, only the yellow indicator lights up in the Scratch software.

Did anybody have a similar experience and can give me a hint on what to do?

Thank you in advance.

First of all, many thanks for doing the work to create this great extension.

Unfortunately I’m experiencing the same issue as mbbraehler on Windows 7. Everything seems to install and upload correctly and I see the ‘More blocks’ but I get a yellow disconnected indicator (i.e. device is not connected or detected), which I can’t seem to change to connected. I’ve tried rebooting the machine, following the Wedo browser plugin troubleshooting suggestions, etc. Any suggestions?

Hey Scratch afficionados ! @Jonathan @joey @mbbraehler @khanning @learnegy @mattgalvin @MR_STEAM @Steve don’t miss toomrrows’ Community Call at 7pm with Mitch Resnik creator of Scratch :slight_smile: Recap Feb 15, 2015: Mitch Resnik & Orientation Go ask your questions in that thread :slight_smile:


Any update on scratch 2 and littlebits?

@shaiss we are teaching an invention from Scratch camp that is two weeks long and we will be using the Arduino Bit in conjunction with Scratch. I will post our experiences here as we work through the camp. Camp starts July 6th and will go until the 16th then a second session will repeat 20th-30th. I hope to have loads of input.

1 Like

@khanning your link to the littleBits_Base_Project.sb2 file gives a 404 error

I found this link to work best:

1 Like

I just saw this now :0 any updates?

We found that it was actually easier to teach them to use the Arduino programing with the kiddos mostly because of the hoops you had to jump through both with the IT department of the college and with the plug-in it’s self. While using Scratch we were able to light up LED’s just fine but not much more than that. We were really hopping for motor control, but could not get that working in time for the camp. We ended up just doing a demonstration of it in Scratch and actually played with it with Arduino code.

Is this process as described above for the online version of scratch or scratchx or our local Windows version?
I thought the sb2 file (which I can no longer locate) was going to assist us with using the extension on our local version of scratch 2.0 (preferred), but you suggestion to go to an alternative location looks like scratchx.

Hello…I am having trouble getting this to work and am hoping you can help.

I have everything installed (I think). The scratch browser extension is installed and the ino file is uploaded into the arduino. The problem is that in ScratchX, the light indicating connection is flashing between green and yellow. I haven’t been able to find any posts of people with the same problem.

I am running a hp EliteBook 8540p and windows 10. I have tried installing both the chrome plugin and the general plugin for other browsers. Both have the same result, exiting after 3-4 seconds.

Has anyone else experienced this problem?

My Windows 10 is not allowing me to get login to my laptop! Even I am submitting a correct password still facing problems.Failed to login is what I am getting.
Will Hope get a solution?