Codebit stopped running programs?

When we first used the codebit today, it worked great.

Now, though, it connects (LED turns green), and when I click UPLOAD the LED on the codebit the LED blinks white, but then it goes back to green and doesn’t run the program.

Any ideas?

I’ve tried:

  • unplugging the codebit
  • unplugging the dongle
  • plugging in via USB (it goes into an update mode but won’t update when i try – it gives me one tick and two crosses)
  • restarting the code kit app
  • pressing the button on the codebit for varying amounts of time
  • plugging in the power bit using USB or using the battery
  • putting the codebit dongle in different USB ports of the computer

I’m on a Windows 10 machine.

(also tried rebooting. Also, now, plugging via USB makes Windows say “device not recognized”… not sure, but it sort of feels like the codebit is dying in front of my eyes…)

Hi there! I’m so sorry to hear you’re having trouble with your Code Bit!

Please write to us at support@littlebits.cc and we’ll be happy to help you out.

Thanks, this was indeed resolved by support sending me a replacement.