Buzzing sound in the background

hi @alexpikkert and @pjd and @JackANDJude !
Thank you Alex for taking time to study the mini pops project and for finding a solution to the delay of the sequencer pulses : you’re the best ! :clap:
I’ve given it even more time (30) and also adapted the tempo control,so that the extra delay for the pulses, are compensated.
Could you give it another try ?
In the meantime doing so, I programmed 4 new extra patterns and these can be controlled by the dimmer at a1.
I’ve uploaded a new ino file with the updated sketch to the MiniPops project. It’s best that you download ALL files ( including kits, patterns and waveforms and minipops.ino).
Unlucky for me, 5V to the arduino gives buzzzzzzz., so I really need the 4.6V adapter and opto circuit :open_mouth:
Tomorrow, I will create a optocoupler bit with the HDK.
Many greetings

2 Likes

version 3 with 8 rhythms and better sequencer trigger output on D1
:musical_score: :grinning:

1 Like

3 posts were split to a new topic: Cardboard Sequencer & Noisemakers

Hi Frank @Frankje
Can you maybe rewrite the beatbox pops ino program for an arduino UNO or NANO?
It seems to work only for the Littlebits W6 Leonardo version… :grinning:
I got this question on my Youtube channel…

Hello @alexpikkert
Its best to ask pjd to transfer the code to Arduino Uno.
He has developed the program so he will certainly know how to do this properly.
I just created new sound samples and patterns for the drum loops.
Wish you the best,
Frank

1 Like

Thanks Frank,
I will try.
Greetings,
Alex

@alexpikkert I think @pjd mirror posted all his littleBits projects on his site. Maybe check here to see if he originally wrote it for Uno?

http://sandsoftwaresound.net/source/arduino-project-source/arduino-beat-box/beat-box-beatbox-ino/

1 Like

I can’t tell exactly how to set this up with the proto-bit. Can you give more instructions? Thanks

1 Like

Did I make a mistake? I still get the same buzz but at just a tad different frequency. Output say 4.59v

1 Like

Hi @brohoho
Your protobit circuit seems good for powering your bits.
Did you also use the filter bit (as described in the project) ?

I’ve tried it this morning and it sounds fine. Can you upload a sound snippet ?

This is the link to the original MiniPops arduino file. Maybe you have a bad sketch ?

Greetings

1 Like

I downloaded your sketch and get the same buzz. I will try to make the filter on a proto bit. I don’t have the perf board or ends to do like you did. It may take me a bit of trial and error to get it. I’m not great at reading schematics nor understanding exactly how the proto bit is setup.

Hi @brohoho,
This is how the protobit works:
The input side ( +5Volt, GND and data) is connected to the lower screw connector
The output side(+5 Volt, GND and data) is connected to the upper screw connector.
When the three black connector pieces (1,2,and3) are in place, the input side is directly connected to the output side,
If they are removed, the input side and the output side are disconnected from each other.
This gives a lot of possibilities to connect several things in a littlebits project.
Hope this helps to undestand how the protobit works, :grinning:

2 Likes

Hi @brohoho and @alexpikkert
thank you Alex for this great drawing, I always had to look how the connections are made :grinning:

So, for the circuit :
If you’re not familiar with perfboard, you can always wire the filter circuit to a littlebits Proto Bit.
Here’s a picture of how this can acomplished.


Don’t forget to put 2 jumpers on positions 1 and 3 (left and right, center is open)

This should also work.
greetings

2 Likes

You guys are awesome. Thanks for the help. Completed and working. Buzz is gone.

2 Likes

Hi @brohoho @alexpikkert @JackANDJude

You’re welcome ! This is what this forum and Littlebits are all about, helping wherever we can :grinning:

I hope you’re enjoying the MiniPops project :grinning:

Which brings me to a question :
I’ve seen my inventions back in my profile (YippeeYaYee). However, when I looked at my MiniPops project, the arduino files were not correct. When I edit them in the inventions editor, it seems I cannot add these back again (only image files).
I solved this by adding a link to my dropbox. But is this the way it should be done ?
My other inventions (string synthesizer) suffer from the same problem.
You can download these files, but they are not working in arduino IDE.

Greetings

Can someone try this also with mine or their files ?

2 Likes

Hi @brohoho,
Great to see it is ok now !
Just curious, does it work now also without the first voltage-drop filter, the one directly after the powe bit ?
:face_with_monocle:

Hi @Frankje,
Thanks for discovering this error.
Most of my projects are in the classroom now without additional files. Ino and pdf files are gone and if they are present they give an error when downloaded…
I will check my inventions and try to correct it.
They have been migrating so many times, I hope the classroom will stay stable in the future.
Publishing inventions is the essence of Littlebits.
:grinning:

1 Like

Hi @alexpikkert
So I’m not the only one it seems.
So, my solution is to edit the inventions and add a link to Dropbox where visitors can download the necessary files.
Greetings

1 Like

Hi @Frankje,
I can restore my ino files in existing projects, but adding PDF and ZIP files fails.
I have sent a message to support@litlebits.com about this error. Wait and see…:wink:

It works fine without the voltage drop bit. So it seems the buzz fix really just needs the filter. The voltage drop bit did nothing to stop the buzzing for me by itself.