Ask a littleBits engineer

Thanks for your reply. I am running littleBits and the Ardunio IDE on an iMac with OSX El Capitan (10.11.1). Right now, I have the power module with battery and the processor board connected to the USB port. The power board is shut off. I am going through the the Getting Started with Arduino procedure (Getting Started with Arduino), and expect to have further results (or lack thereof) to report in my next post.

I have Arduino Leonardo, version of Arduino IDE not given, but presumably, it is version 1.0.5 offered at the web page: Getting Started with Arduino. One overriding problem seems to be that the IDE offers only a Bluetooth Port, not a serial port. While it would be interesting to me to establish the connection over a Bluetooth Port, I need to learn how to activate the Serial Port first. (I would probably need a module with Bluetooth capability anyway).

Many years ago (maybe 30 years ago?), I worked with Motorola 6800 series microprocessors, and was used to having extensive listings of hexadecimal instructions. Probably a topic for another forum, but it will give you a little more of an idea of my background.

Microprocessors in general interest me; the very study of them seems for me to be enough of a justification for me to work with them. However, I have also considered the possibility of using them to control signaling and lighting on my model railroad layout. After that, who knows what other applications I may be able to develop.

Anyway, I will proceed with the basic set up, and welcome any further feedback you may have based on the information I have thus far presented.


I changed the digitalWriter pin number parameter from 13 to 05, and, finally got some blinking – yellow lights on the “at Heart” board blink a few times before they stay off for good. the red lights on the bar graph worked in chase light fashion a few times before they stayed off for good. Finally, the green lights stay on at all times, whether a program is being executed or not.

For some strange reason, after a couple of runs of the Blink program, Tools>serial port is dimmed again, and only a Bluetooth port is available. I tried restarting the IDE, and shutting off the power module and turning it on again before running the Blink program. None of this made the serial port accessible, or restored the action.

It seems there should be a way to reset the serial port connection so that it shows up under Tool>Port – what is it?

I have more to say about my experience with the littleBits Ardunio coding program, but for now, I’ll concentrate on this problem.


Hi @Leo_1020,
There is a possibility that the Bluetooth software in your computer is interfering with the USB serial port allocation.
(on a windows pc it is advised to remove all software \firmware that could also occupy serial port definitions).
Maybe it could be the problem on your computer too.
I think it could be worth a try…
Is it possible to block out the bluetooth part ?

Hi @Leo_1020 and Alex (@alexpikkert),

I’ve been experiencing the Arduino’s ‘port problem’ since I’ve been programming them. I have noticed the problem happens at random, it’s more common with 3rd party boards than with genuine Arduinos, and it seems to have been greatly improved with 1.6.5 of the IDE. (Leo: you can find the version of the IDE by looking in the top left corner of the About Arduino dialog in the File menu.)

Look through the littleBits forum for topics on it - there have been a number of possible remedies posted, which, in my opinion, sometimes work.

Alex, I do not think the bluetooth port is interfering. There are always 2 bluetooth ports showing on a Mac, no matter if the usb port shows up or not. Turning bluetooth off doesn’t seem to change this. The instructions at say to just ignore them.

Hi @Leo_1020 andChris @chris101,
I agree about your remark on the port problem, I only experience this issue on my Littlebits Arduino Leonardo, not at all on my original UNO and Duemilanove. They are 100% stable.
I use IDE version 1.6.6 (the most recent version) and still my Leonardo needs a port set after each change I make in the program… and before each upload…

Hi sean I am trying to connect a MPU6050 accelerometer to the littlebits arduino.
Would you know how to wire/code this information?

Hi @johnjairo,
I am not Sean, but I checked the Arduino site and found this info :smile:
Maybe you can find how to use your accellerometer…

Hi Sean, the Gizmos & Gadgets motor bits are a huge improvement over the older ones, well done. I was curious to see what changed, but I couldn’t find any information on the new ones. Where can I see the schematic for the newer motor bit (o25)?


I am tyring to use a proto module to connect a USB powered humidifier to the arduino module. I have cut off the USB part to expose the wires, and I have one of the wires connected to ground and the other one to the volt power line on the Output side. The humidifier is working, but it is completely ignoring my code, it won’t turn on and off, the power is just passing through. I have no access to any other wires, the humidifier needs to stay sealed, and only those two wires come out of the cable. Could you help me fix it?

Hi Sean,

Can you tell me if the Control hub for Droid can be used for anything else or be re-programmed?


Hi there,

I’m a new user, and just wanna try my luck at Arduino LittleBits with Blink Sketch. However, when I wanted to upload, it gives me this error: "

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\cores\arduino\wiring_analog.c: In function ‘analogRead’:

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\hardware\arduino\avr\cores\arduino\wiring_analog.c:98:1: internal compiler error: Segmentation fault



Please submit a full bug report,

with preprocessed source if appropriate.

exit status 1
Error compiling for board littleBits w6 Arduino Module (Leonardo).

Hi Sean.

I don’t have an Arduino bit but am using a code bit. Is there a way to generate a random number from the code bit app?


Mordechai Smolarcik
KHDS Makerspace

Hello, were you able to solve this problem? How? Thanks