Ask a littleBits engineer

Hi i’m working on project that will require to put the littlebits into a fairly small space.
is this safe? should there be some sort of ventilation?
i’m so very new to all of this, but i want to make sure this project works out.

Hey @sean_littleBits. I enlisted a coder to help me with the project and here’s the thread. Twitter Counter : LittleBits and CloudBits

If @jakilevy has not yet cracked the code for a wee piece of logic that is missing, I’ve suggested that he ping you. This is a super exciting project that will be hitting the public (in front of ~2,000 coders !!) on 11/16. It’s in that sweet spot where challenging, fun, and terrifying intersect.

Yours in
:bitstar:-ness,

Bridget

Hi Bridget,

Sounds good!.I’ll be keeping an eye out for any questions from @jakilevy.

1 Like

Thanks, @sean_littleBits! The piece of logic I can’t quite get right is counting a CloudBits “ping.” Using IFTTT, we are successfully -

  • listening to tweets via hashtags
  • pinging CloudBits at 100% (or another %) for 1 second
  • based on that ping AND percentage, we’re lighting up a bar graph Bits

However, I have not been able to “count” these pings (aka tweets).

For example, if there’s 1 tweet, ping bargraph @ 20%.
If there’s another tweet, increment the tweetCounter variable, and increase the brightness bargraph lights. And so on.

The code I’ve written so far can count Button Presses, which is great. But it’s not counting CloudBits “pings.”

Thank you for any guidance you can provide (I’ve also posted to the arduino.cc forums).

FYI - @JackANDJude sent over some useful code here which I’m still wrapping my head around - Twitter Counter : LittleBits and CloudBits

I recently purchased the Arduino Coding Kit. I initially plugged in my Arduino board and successfully uploaded the drivers and got it programmed into my IDE. When I tried the next step (plugging in the button module), the ports disappeared. I tried using a different pink module and still no ports. I’ve also disconnected the pink modules and gone back to just the Arduino and still no ports.

Do I need to reconfigure ports every time I add a new input? I had planned to use this technology for students but if that’s the case, it’s basically useless.

Help please!

Hello, @Allison_Martinson! :smiley:

Which operating system are you running the Arduino IDE on? I do not have this issue on my PC system.

When you are adding new modules, you have to make sure they are all connected to a power bit. When you disconnect the power and then reconnect it, the Arduino will reboot. If you want the Arduino remain “always on”, you will have to add one solder blob to the two small, metal pads to the right of the d0/rx led.

Doing that minor mod will connect the usb power line to your Arduino. It will also power all bits connected to the three outputs. However, to power bits on the three inputs, they will still need to be connected to a power bit. :electric_plug:

I am running a PC/Windows 7.

Everything is still connected to a power bit. It just isn’t recognized by my computer.

I have similar issues, @Allison_Martinson. Every time I disconnect power, Windows reassigns the port so that I need to select the new port number again and again, listening to the windows bing-bong (pause) bong-bing. If you are experiencing the same issue, I think it requires a bit of patience at first to develop the rhythm.

@Allison_Martinson If the sound is driving you nuts you can turn it off:

Control Panel => Sound => Sounds Tab => change “Device Connect” and “Device Disconnect” to no sound.

If you are tired of windows iterating your ports you can clear them in your registry settings. Check this link out to see how to do it.

1 Like

I don’t care about the sound. I want my arduino to recognize ports.

I’m not getting a reassigned port. I don’t have a port at all. The ports section of my IDE is shaded and I can’t select it. When I tried using Codebender, it could not find any ports.

Arduino.cc suggested reseting my board, but unfortunately, I can’t seem to find a reset button on my littlebits board. I think this whole box is going back to the manufacturer at this point and I’ll stick to regular arduinos.

Hi Allison,

Try using the recovery procedure outlined in this post.

@Allison_Martinson the recovery procedure posted by @sean_littleBits worked for me when I accidentally uploaded a bad sketch that stopped the Arduino from being selectable in the port menu.

I hope you give your littleBits Arduino a second chance as it is very useful even if you have other Arduinos on hand. It is in the official Arduino shop, so I am sure that once you get it running it will be as smooth as using any other Arduino. :innocent:

1 Like

I have a littleBits Ardunio Leonardo board, and am finding that under Tools>Port, the only port that I am offered is a Bluetooth port, not a serial port. How do I get a serial port?
Regards,
Leo

Hello Sean,

Our son has the Arduino coding kit and iPad mini. Can he code on the iPad and get the code into the Arduino Little Bit?

Does the Little Bit require the USB connection? If so, could he code on a Microsoft Surface Tablet and get the code to the Little Bit from the Microsoft Surface to the Aurduino Little Bit?

Thanks, Nathan

Hi Nathan, I’m not Sean, but I have looked into programming Arduino with iOS, but have not found a way to do so. Arduino software runs on Mac, Windows, and Linux, therefore, the MS Surface should work just fine.

Here is the Arduino software page, which links to everything you’d want to know about it:

https://www.arduino.cc/en/Main/Software

Thanks so much for the response. I appreciate it.

HI, @Leo_1020! Welcome to the forums! You did the right thing to post your question in the Arduino & Programming section. Perhaps you could add more details to your question there? Like what version of Windows you are running and the circuit you are using. The littleBits Arduino always needs a power module to stay on - that might be a help.

Where are you from and what kind of projects are you into? We’d love to know more about you! :smile:

Thanks for your reply. I am running littleBits and the Ardunio IDE on an iMac with OSX El Capitan (10.11.1). Right now, I have the power module with battery and the processor board connected to the USB port. The power board is shut off. I am going through the the Getting Started with Arduino procedure (Getting Started with Arduino), and expect to have further results (or lack thereof) to report in my next post.

I have Arduino Leonardo, version of Arduino IDE not given, but presumably, it is version 1.0.5 offered at the web page: Getting Started with Arduino. One overriding problem seems to be that the IDE offers only a Bluetooth Port, not a serial port. While it would be interesting to me to establish the connection over a Bluetooth Port, I need to learn how to activate the Serial Port first. (I would probably need a module with Bluetooth capability anyway).

Many years ago (maybe 30 years ago?), I worked with Motorola 6800 series microprocessors, and was used to having extensive listings of hexadecimal instructions. Probably a topic for another forum, but it will give you a little more of an idea of my background.

Microprocessors in general interest me; the very study of them seems for me to be enough of a justification for me to work with them. However, I have also considered the possibility of using them to control signaling and lighting on my model railroad layout. After that, who knows what other applications I may be able to develop.

Anyway, I will proceed with the basic set up, and welcome any further feedback you may have based on the information I have thus far presented.

Regards,
Leo1020

I changed the digitalWriter pin number parameter from 13 to 05, and, finally got some blinking – yellow lights on the “at Heart” board blink a few times before they stay off for good. the red lights on the bar graph worked in chase light fashion a few times before they stayed off for good. Finally, the green lights stay on at all times, whether a program is being executed or not.

For some strange reason, after a couple of runs of the Blink program, Tools>serial port is dimmed again, and only a Bluetooth port is available. I tried restarting the IDE, and shutting off the power module and turning it on again before running the Blink program. None of this made the serial port accessible, or restored the action.

It seems there should be a way to reset the serial port connection so that it shows up under Tool>Port – what is it?

I have more to say about my experience with the littleBits Ardunio coding program, but for now, I’ll concentrate on this problem.

Regards,
Leo1020