Arduino Troubleshooting

Shorting the 2 inner pins until the IDE starts the upload worked great. Thank you MR_STEAM and manitou for your help! I’m very happy to have my Arduino bits working again.

Thanks for the input @manitou! Glad it worked for you @matkins85! Be careful with those programs! :smile: At least you now know how to correct the issue!

I have tried every combination…diconnect all modules, follow instructions…compiles, says loading and then I turn on power…no go. Yellow lights blink…attach LED module…no control. Sometimes lit, other times stays off. Have wasted hours…attach an UNO and no problem, computer sees it, and loads to it. Same USB port. Just changing board id to UNO or Leonardo as needed. Littlebit module is not reacting to program loads.

Help. Thanks, Glenn

I tried shorting the inner holes and outer holes…nothing works. Sketch BLINK will not upload. Losing hope.
Tried a windows computer, nothing, never could find a port to load up.

Hey there! Saw you posted on our Project Forum too. We’re going to take this question back to the lab and get you an answer ASAP.

Hey @glennmartinez,

I have a few questions to ask, since I assume you followed every step on this link Arduino Setup. . Sorry if I ask dumb questions:

  1. Is this your fist attempt connecting the Arduino?
  2. Once your Arduino Module is connected to the computer, does the computer show that it was connected & recognized? (shows a display box that says Arduino connected?)
  3. Does the settings allow you to choose a Port for the Arduino? If so, does the Port number change from every upload attempt?
  4. Are you uploading the code to the Arduino or are you verifying the Arduino code?
  5. Is the Arduino powered on when you are uploading the sketch?
  6. When you attempt to upload the code, does the IDE say that it is “done uploading”? Does the RX/TX LEDs blink twice once the code is uploaded?
  7. Can you post the code that you are using?

Same issue, the modules don’t always connect perfectly when laid flat – so LEDs and/or power turn on/off. Very annoying gift so far. Think the Littlebits arduino module should have kept the lessons learned from the the original arduino. Make sure the board can work stand alone right away. Use USB power, when plugged in, put back a power light on the primary board (to know it’s on), and put back the onboard LED on pin 13 - on the primary board. So on day one I can tell it’s working, and more easly guess why it isn’t. Because you’ve dropped this you can’t easily diagnose reported issues.

Another item I found frustrating was installing the unsigned USB driver. Although some Windows setups will allow you to install it, others will may just block the action with no other options. There is not much info
how to resolve this problem. Checking if the driver is signed or not is a changeable option. Press Start—>MyComputer—>Properties—>Hardware—>DriverSigning set to ‘Warn’ not ‘block’. Then reinstalled the Driver again.

the USB cable to the LB arduino does NOT provide power (go figure). You need to provide power to the arduino via a power bit module

Here is a little unofficial tip. The current Arduino modules have a solder jumper on them that allow you to connect the USB power to the littleBits power line. All it requires is for you to bridge this jumper with some solder. This would allow you to power your Arduino module and a small circuit using the USB port’s power. Not having the Arduino module run off USB power was a conscious choice as it breaks our littleBits pedagogy which says that all circuits need to begin with a blue power module.

If you head to the Arduino modules page:

And, in the image of the module directly above the “d0/rx” is a small pair of unmarked solder pads. Bridge this jumper with solder and you’ll have the USB port power your circuits. Word of warning, you should do this with CAUTION as it may be possible to permanently damage your Arduino module. Your USB port supplies less current than a p1-power module and so you may have trouble using lots of high current modules like the servo, dc motor, cloudbit, etc.

so after soldering the jumper is it “safe” to have both USB power AND a LB power module active at the same time?

Thanks much for the tip. I’m going to wire the pads to a jumper glued to the top of a module. It would provide a quick prototyping with just using led bits, then remove the jumper and add the higher current modules. I would think you still need to power any pink input bits i.e. led bits connected to the arduino module with a blue power bit correct?

Yes it is safe. In fact there is a resettable fuse on the current coming from the USB power so if the draw is too large it’ll temporarily disconnect power, thus protecting your USB port and your circuit.

Yes, you are correct. The bits connected to the inputs of the Arduino will need a power module connected. This helps not with powering the input modules but to provide them with an input signal. In this case, that input signal would be 5V from the power module.

Now you probably see why we didn’t choose to allow power from the USB port to begin with. For beginners, it can get messy explaining why modules with their outputs connects but their inputs disconnected don’t function correctly. However, this is on our radar and we’re hoping to address this in the future.

Thanks a lot, I soldered the jumpers together and it makes prototyping just a bit easier, at least until we need to do something that needs more current. Nice to know the battery can be connected at the same time. Thanks again.

OK, even with the jumpers bridged, you may still need the blue power module – but not because of limited USB current. The ‘push-Button’ module seems to be designed to only work with power flowing through it. Unlike the dimmer it will not take power from the Arduino. This means for projects like , the power module can’t be moved anywhere else or the button can’t be used. As a visual setup, having the power enter the circuit through a switch seems very misleading. It implies you’re cutting power to the Arduino when the button is pressed, however it’s obvious this is not happening.

I honestly think the Button module has a design error, this seems very limiting, or I might be doing something wrong. Regardless the justification above that every circuit needs the blue power module seems to fall flat when we have it entering this circuit using a switch.

So, although the USB jumpers work great for keeping the Arduino board powered and connected to the computer, you may still need both solutions. Without using the jumpers the board turns on/off more frequently messing up the port connection.

I have the Arduino module and I have coded a Sketch that is supposed to flash both LED lights. It does do that but my Windows 8.1 computer will disconnect the module after about 4 seconds then reconnects it. The sketch then never stays on. The Arduino module also only powers up when plugged into a computer. Are these normal? Here’s my Sketch’s code.

// First Arduino Sketch!!!
int ledPin = 1;

void setup()
//initialize pins as outputs
pinMode(ledPin, OUTPUT) ;

void loop()
digitalWrite(ledPin, HIGH) ;
delay(1000) ;
digitalWrite(ledPin, LOW) ;
delay(1000) ;

Hey @ClanScorpia,

Does the computer “disconnect” during the uploading process or does it disconnect after the sketch is uploaded?
Also, the two small LEDs d0/rx & d1/tx illuminates once the power is applied and it is connected to a computer, which doesn’t mean that it isn’t powered on.

After a sketch is uploaded to the Arduino, remove the Micro USB cable first, and then remove the power supply. Test it to see if this holds the program. If not, replace the battery to the power module. Let us know if this helps!

Thanks MR_STEAM,
I did the BLINK Sketch and the Arduino works fine. I think I was just having a newbie moment. Get the littleBits for Christmas. Thanks for the quick reply!

I’ve been playing around with my Arduino and I keep getting the error avrdude: ser_open(): can’t open device “\.\COM5”: The system cannot find the file specified.

avrdude: ser_send(): write error: sorry no info avail

Any specific reason for this? The code I used is down here.

void setup(){
pinMode(5, OUTPUT ) ;
pinMode(A1, INPUT ) ;

void loop(){
digitalWrite(5, HIGH);
delay( (1024 - analogRead(A1)) );
digitalWrite(5, LOW);

Hey @ClanScorpia,

Try deleting all COM devices from the device manager. Also, uninstall the Arduino IDE program and reinstall the latest version.