Arduino bit not recognized

I’m using the Arduino bit with Windows 10. At first I had some problems connecting the bit with USB. I got the error ‘Device Descriptor Request Failed’. After some fiddling (disconnecting, reconnecting, uninstalling reinstalling) it started working. Didn’t know why though. But I was able to work with it the entire day. At the end of the day I put all my bits in a box. But when I wanted to start working again the next day, I got the same error as before. Only this time I’m not able to resolve it. I have the same problem on my Windows 8 laptop.

Hello @roelkok,
I think the error you describe points at a failure of communication between the hardware. So it could be a hardware failure or maybe also a driver issue.
Can you use other equipment without error on the same USB connection?
The Arduino IDE software also installs drivers for communication with the Arduino bit.
Can you recognize the Arduino Leonardo and the (virtual) COM port it is normally using after installing the IDE?
Or does the error pop up before, then maybe the laptop USB drivers are not installed correctly…
Hope this helps a bit… :grinning:

2 Likes

Hey thanks for your reply @alexpikkert

I can connect other devices like my camera to the same USB port without problems. I’ve installed the drivers that came with the IDE. I had the board working before. I can see the COM ports in device manager when I display the hidden items. But they never become active.

I guess it’s a hardware issue then.

Hi @roelkok,
That’s good news I think !
I had the same issue of seeing COM ports that could not be activated, it was caused by a wrong type of USB cable I used. It was only suitable for power charging and not for data transfer. So it could be a wacky cable or cable connection… Worst case a hardware failure in the Arduino itself… :fearful:
See this forum thread:


:grinning:

Hey @alexpikkert
I tried different USB cables of which I knew they worked with data transfer, but I kept having the same problem. I stopped by the Littlebits store in New York today and they swapped the module with another one and that one just worked. So I guess I had just a faulty one. One other thing they told me is that some code like an infinite loop (inside the main loop) could cause the Arduino bit (or Leonardo boards in general) to lock up and become unresponsive. Which is also good to know.

2 Likes

@roelkok, how did you like the store? If you live in the area and plan to go to MakerFaire, please let us know here: Who's Coming to Maker Faire NY?

and consider coming to the event at the store on Saturday evening, Sept 26th. :slight_smile:

Oh, and what are you making lately? :ear:

I really like the store. Friendly people and a great place to play around. Definitely can recommend anyone to visit it when they’re near.

Currently I’m playing around with the arduino bit and cloudbit to see what’s possible.

1 Like

Cool. I used the cloudBit and Arduino to make a Smart Playhouse.

Hi @roelkok,
Good to see your Arduino issue is solved now !
Indeed the Littlebits teams are very friendly and helpful to solve issues like you had !
:grinning: :grinning: :grinning: