All I get are clicks

Just opened my kit for the first time, can’t get it working. I tried a different battery, neither the random noise circuit or the oscillator circuit do anything. Tried cleaning contacts,… the only thing that works is the Red LED on the power supply module. Should I assume I’ve got a defective one and return it?

I should mention the clicks seem to occur when I wiggled the modules around. There’s no sound if I do nothing. I just tried an external speaker and got a VERY faint tone, so there’s something wrong apparently.

Hey @drjblog

I am going to reach out to you through our support system. Sorry for the trouble!

1 Like

Mine did the same thing and the speaker was missing a capacitor. Take a picture of the speaker board on the bottom.

Customer Service sent me a replacement; I just mailed the defective one back. The new speaker module solved my problems!

Had this same problem with my speaker; compared the bottoms of several speakers and found that, sure enough, the defective one doesn’t match the other two.
Will contact customer support. Thank you for the help!